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Edit / Paste (Strg+V) : 

Inserts the contents of the clipboard into the active image. The pasted 
image is automatically selected, allowing it to be dragged with the mouse. 
Click outside the selection to terminate the paste. Select Edit/Undo to 
abort the paste operation. 
Remark:  With copy and paste you can arrange selected image areas 
   and other results like histograms on the print-form. 

 
 
 
Setting of a ROI (region of interest)  
 

The selection of a well defined section of an image (region of interest, 
ROI) is a basic operation for image analysis and is very important in our 
Image Processing course. It can be done in the following ways: 

 
Edit / Selection / Select All  (or better:  Strg+A) : 

Creates a rectangular ROI that has the same size as the image.  
 
Edit / Selection / Select None  (or better:  Strg+Shift+A) : 

Deactivates the selection in the active image. 
 
Edit / Selection / Specify … : 

This command allows you to position a ROI precisely. The ROI is defined  
by specifying (in terms of pixels) the size of the ROI box (width and 
height) and the position of the upper left corner of the ROI (x- and y- 
coordinates). The values can be selected in the “Specify-window” shown 
below: 

 
 
 
Manual ROI setting (with the button “rectangular selection“ on the tool bar): 

Manual ROI setting is performed with the „rectangular selection“ tool 
button (left button in tool bar, see Fig. below).  
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Creating the selection is done by a mouse-drag. After a ROI selection use 
the points in the corners to resize. With the shift key held down during the 
drag the ROI is fixed to a square. As a selection is created or resized, its 
location, width and height are displayed in the status bar. 
 
Using the arrow keys you can move the ROI box. With the arrow keys 
and the alt key held down you can change the width or the height of the 
ROI.  
 

 
 
Text Annotations (with the button “text tool“ (A) on the tool bar): 
 

Use the text tool to add text to images. Left mouse click on the text-tool- 
button and double-click on the image where the text should be positioned 
creates a rectangular selection containing one or more lines of text. Use 
the keyboard to write the text and the backspace key to delete characters. 
The final position of the text can be selected by a mouse drag. Use 
Edit/Draw (better: Strg+D) to permanently draw the text on the image. 
Use Edit/Options/Fonts, or double-click on the text tool, to specify the 
typeface, size and style. 
 
Remark:   All images, histograms, LUT-boxes and other results should 

be labeled by text annotations on the print-form. So, the 
final print-form contains a clear description of all displayed 
components and a short specification of the applied analysis 
or evaluation.  
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Measuring DNA Contour Lengths
This is an example of how to measure the lengths of DNA contours on images acquired using an
atomic force microscope (AFM). It requires ImageJ 1.30 or later.

 
Figure 1. AFM image of 538 bp DNA fragment deposited on mica.

In this example, we measure the length of the DNA contour in the lower right corner. The field
width of the image is 500nm. The image is from M. Lysetska, et al., "UV light-damaged DNA and
its interaction with human replication protein A: an atomic force microscopy study", Nucleic Acids
Research, 2002, Vol. 30, No. 12 2686-2691 (nar.oupjournals.org/cgi/content/full/30/12/2686),
used with permission.

 
Figure 2. Set Scale Dialog Box.

Use the Analyze/Set Scale dialog to define the spatial scale. Enter the image width in the
"Distance in Pixels" field, enter the field width in the "Known Distance" field, enter "nm" as the
"Unit of Length", then click "OK".

http://nar.oupjournals.org/cgi/content/full/30/12/2686
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Figure 3. Zoomed and spatially calibrated image.

Use the magnifying glass tool to zoom in on the DNA contour to be measured, in this case, the
one in the lower right corner of the image. To zoom out, right-click or alt-click with the
magnifying glass tool.

 
Figure 4. ImageJ toolbar with segmented line tool selected.

This is the ImageJ toolbar. Use the segmented line tool (sixth tool from the left) to outline the
DNA contour. The three tools on the right end of the toolbar are tool macros.

 
Figure 5. Selected DNA contour.

Use the segmented line tool to create a line selection that outlines the DNA contour. To finish
outlining, right-click, double-click or click in the box at the starting point. The line selection can

http://rsb.info.nih.gov/ij/developer/macro/macros.html#tools
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be adjusted by clicking and dragging the the tiny black and white "handles" along the outline.

 
Figure 6. Results Table.

Finally, use the Analyze/Measure command to measure the length of the DNA contour, in this
case 181nm. Measurements can be transferred to a spreadsheet by right-clicking in the "Results"
window, selecting "Copy All" from the popup menu, switching to the spreadsheet program, and
then pasting.

| Examples | Home |

http://rsbweb.nih.gov/ij/docs/examples/index.html
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6 Undo and Redo
Probably the first thing you will notice is that ImageJ does not have a large undo/redo buffer. Undo
(Edit▷Undo [z]↓) is currently limited to the most recent image editing / filtering operation. With time you will
appreciate that this is necessary to minimize memory overhead. Nevertheless, with IJ 1.45 and later, Undo
[z]↓ is, in most cases, undoable and can be applied to multiple images if Keep multiple undo buffers is
checked in Edit▷Options▷Memory & Threads…↓

If you cannot recover from a mistake, you can always use File▷Revert [r]↓ to reset the image lo its last
saved state. For selections, Edit▷Selection▷Restore Selection [E]↓ can be used to recover any misdealt
selection.

In ImageJ the equivalent to ‘Redo’ is the Process▷Repeat Command [R]↓, that re-runs the previous used
command (skipping Edit▷Undo [z]↓ and File▷Open… [o]↓ commands).

See Also: Plugins▷Utilities▷Reset…↓, Multi Undo  plugin

Up Part II: Working with IJ
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You are here: Welcome to the ImageJ Information and Documentation Portal » GUI Commands » analyze » Tools

Tools

This submenu provides access to various image analysis
plugins.

Save XY Coordinates...

Writes to a text file the XY coordinates and pixel value of all non-background pixels in the active image. For
grayscale images, writes three values per line (x, y, and value), separated by spaces. For RGB images,
writes five values per line (x, y, red, green and blue).

For grayscale images you can specify the background value in a dialog.

Note that the y coordinates are inverted with respect to those shown in the status bar (y=0 at the bottom)
unless you select the appropriate checkbox (this unusual behavior is for compatibility with old versions).

Fractal Box Count...

This command is used to estimate the fractal dimension of a binary image. Counts the number of boxes of
an increasing size needed to cover a one pixel binary object boundary.

The sequence of box sizes is defined in the Box Sizes field.

Check Black Background if the object is white [255] and the background is black [0].

The box size and the number of boxes necessary to cover the boundary are plotted on a log-log graph and
the fractal dimension determined from the slope of the log-transformed data by linear regression, i.e.

For more information, see the “Fractal_Box_Counter.java” source file.

Analyze Line Graph

ImageJ can be used to recover numeric coordinate data from scanned line graphs using the following
procedure. Steps 1-6 are not necessary for binary (black and white) graphs. For practice, use the
File>Open Samples>Line Graph sample image. 

1. Open the image containing the graph.
2. Open the thresolding tool (shift-t).
3. Adjust the threshold so the graph is highlighted in red.
4. Click on “Apply” (make sure foreground is black and background is white).
5. Close the thresholding tool.
6. Use the oval selection tool as an erasor (press backspace to erase) to isolate a single curve (note:

background color must be white).
7. Select the curve by clicking to the left of it with the wand tool.
8. Use Edit>Clear Outside to erase everything but the curve.
9. Use Analyze>Tools>Analyze Line Graph get the XY coordinates.

ROI Manager

The ROI (Region of Interest) Manager is a tool for working with multiple selections. The selections can be
from different locations on an image or from different slices of a stack. All selection types, including points

D = - slope
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and lines, are supported.

Click Add to add the current selection to the list, or press “t”, the keyboard shortcut for the
Edit>Selection>Add to Manager command. The Roi manager creates a three part label. The first part
(stacks only) is the slice number, the second part is the X coordinate of the selection, and the third part is
the Y coordinate. Click on a label to restore the associated selection to the current image. With stacks, the
selection is restored to the slice it came from. Click on Show All to display all the selections on the list.
Hold down the shift key while clicking Add to “add and draw” and the alt key to “add and rename”.

Install the ROIManagerMacros macro set and you will be able to add a selection by pressing the “1” key,
add and name by pressing “2”, add and draw by pressing “3”, and add and advance to the next slice by
pressing “4”.

Update replaces the selected ROI on the list with the current selection. This is usually a modified version
of a selection from the ROI Manager list.

Delete deletes the selected ROIs from the list. Deletes all the ROIs if none are selected.

Use Rename to rename the selected ROI (requires v1.35c or later).

Open opens a ”.roi” file and adds it to the list or opens a ZIP archive (”.zip” file) and adds all the ROIs
contained in it to the list. Use the Open All macro [insert link here] to add all the ”.roi” files in a folder to the
list.

Save saves the selected ROI as an ”.roi” file. If none are selected, saves all the ROIs in a ZIP archive.

Measure measures all the ROIs on all the images in a stack as long as none of the ROIs are selected,
and none are associated with a particular slice (all have names like “xxxx-yyyy”) or all are associated with
the first slice (all have names like “0001-xxxx-yyyy”).

If this is not the case, use the More>Multi Measure function, added in ImageJ 1.38m. Multi Measure,
based on a similar function in Bob Dougherty's Multi_Measure plugin, measures all the ROIs on all the
images, creating a results table with either one row per image or one row per measurement.
With a stack, you will be given the option to measure all the slices if all items are associated with the first
slice or all have labels in the form xxxx-yyyy. Use the Analyze/Set Measurements command to specify the
measurement options.

Deselect deselects any selected items on the list. Delete, Save, Measure, Draw, Fill, Label and Combine

http://imagejdocu.tudor.lu/lib/exe/fetch.php?hash=795590&media=http%3A%2F%2Frsb.info.nih.gov%2Fij%2Fdocs%2Fimages%2Froi-manager.jpg
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work with all items on the list when none are selected.

Show All causes all selections on the list to be non-destructively displayed on the current image. Click
again to stop displaying the selections. Click on a label (selection number) in the image to activate the
corresponding selection on the ROI Manager list.

More» displays a drop down menu with six additional commands:

Draw draws the outline of the selected ROIs using the current foreground color and line width.
Draws all the ROIs if none are selected. Click in the Image>Color>Color Picker window to set
the foreground color. Use Edit>Options>Line Width to set the line width.
Fill fills the ROI using the current foreground color .Fills all selections on the list if none are
selected. Click in the Image>Color>Color Picker window to change the foreground color.
Label labels and outlines the selected items using the current foreground color. Labels and outlines
all selections on the list if none are selected. Unlike Show All, this changes the image contents.
Combine uses the union operator on the selected items to create a composite selection. Combines
all the items if none are selected.
Split separates a composite ROI into simple ones and adds them to the ROI Manager.
Add Particles adds objects segmented by the particle analyzer to the ROI Manager. Requires that
“Record Starts” be checked in the Analyze>Analyze Particles dialog box. Particle analyzer
objects can also be added to the ROI Manager by checking “Add to Manager” in the Analyze
Particles dialog box.
Multi Measure, (based on a similar function in Bob Dougherty's Multi_Measure plugin) measures
all the ROIs on all the images, creating a results table with either one row per image or one row per
measurement.
Sort sorts the ROIs list in alphanumeric order.
Specify lets you specify an ROI in the same way as Edit>Selection>Specify
Remove Slice Info command removes the information in the ROI names that associates them
with particular slices.
Help opens the ROI help page ( at IJ's site) in the default browser.
Options shows a dialog to set the color used in Show All mode and to associate ROIs with slices.

Scale Bar

Draws a labeled calibration bar of the specified Width calibrated units and Height in pixels.

[insert image dialog]

Change Font Size to adjust the labels' font size.

Change Color to adjust the text color and the Background to increase the contrast, if needed.

Change Location to move the calibration bar. If there is a selection, the bar is initially drawn at the
selection.

If Bold Text is checked, labels are drawn bold.

If Hide Text is checked, only the bar is drawn.

Check Serif Font to change the font accordingly.

Calibration Bar

Creates an RGB copy of the current image and displays a labeled calibration bar on it.

http://rsb.info.nih.gov/ij/docs/menus/analyze.html#manager
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Change Location to move the calibration bar. If there is a selection, the bar is initially drawn at the
selection.

Change Fill Color to adjust the bar's background color.

Change Label Color to adjust the text color.

Change Number of Labels to adjust the total number of values displayed.

Change Decimal Places to adjust the number of decimal places present in the labels.

Change Font Size to adjust the labels' font size.

Change Zoom Factor to scale the entire calibration bar.

If Bold Text is checked, labels are drawn bold.

      

http://imagejdocu.tudor.lu/lib/exe/fetch.php?hash=c19de8&media=http%3A%2F%2Frsb.info.nih.gov%2Fij%2Fdocs%2Fimages%2Fcalibration-bar.jpg
http://creativecommons.org/licenses/by-nc-sa/3.0/
http://www.chimeric.de/
http://jigsaw.w3.org/css-validator/check/referer
http://wiki.splitbrain.org/wiki:dokuwiki
http://www.firefox-browser.de/
http://imagejdocu.tudor.lu/feed.php
http://validator.w3.org/check/referer
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Basic Concepts
ImageJ is Free Software
ImageJ is public domain open source software. An ImageJ user has the four
essential freedoms defined by the Richard Stallman in 1986:

1. The freedom to run the program, for any purpose.
2. The freedom to study how the program works, and change it to make it do

what you wish.
3. The freedom to redistribute copies so you can help your neighbor.
4. The freedom to improve the program, and release your improvements to the

public, so that the whole community benefits.

Windows
The "ImageJ" window contains a menu bar (at the top of the screen on the Mac),
tool bar, status bar, and a progress bar. Images, histograms, line profile, etc. are
displayed in additional windows. Measurement results are displayed in the
"Results" window. Windows can be dragged around the screen and resized.
Histograms and plots are ordinary image windows that can be copied to the
clipboard, edited, printed and saved.

Toolbar

The toolbar contains tools for making selections, for zooming and scrolling
images, and for changing the drawing color. Mouse over a tool and a description
is displayed in the status bar. The tools and menus on the right side of the toolbar
are created using macros defined in the file ImageJ/macros/StartupMacros.txt.

Status Bar

The status bar, when the cursor is over an image, displays pixel coordinates and
values. After running a filter, it displays the elapsed time and processing rate in
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pixels/second. Click on the status by and it will display (as shown above) the
ImageJ version, the Java version, memory in use, memory available and percent
memory used.

Progress Bar
The progress bar, located to the right of the status bar, shows the progress of
time-consuming operations. It will not appear if the operation requires less then
approximately one second.

Images

ImageJ allows multiple images to be displayed on the screen at one time. The
active window has its title bar highlighted. All operations will be performed on the
active image. ImageJ supports 8-bit, 16-bit and 32-bit (real) grayscale images
and 8-bit and 32-bit color images. 8-bit images are represented using unsigned
integers in the range 0 to 255. 16-bit images use unsigned integers (0 to 65,535)
and 32-bit grayscale images use floating-point numbers.

16-bit and 32-bit grayscale images are not directly displayable on computer
monitors, which typically can show only 256 shades of gray. Therefore, the data
are mapped to 8-bits by windowing. The window defines the range of gray values
that are displayed: values below the window are made black, while values above
the window are white. The window is defined by minimum and maximum values
that can be modified using Image>Adjust>Brightness/Contrast.

Stacks

ImageJ can display multiple spatially or temporally related images in a single
window. These image sets are called stacks. The images that make up a stack
are called slices. All the slices in a stack must be the same size and bit depth. A
scroll bar provides the ability to move through the slices. Most ImageJ filters will,
as an option, process all the slices in a stack.

ImageJ opens multi-image TIFF files as a stack, and saves stacks as multi-image
TIFFs. The File>Import>Raw command opens other multi-image, uncompressed
files. File>Import>Image Sequence opens a folder of images as a stack. To
create a new stack, simply choose File>New>Image and set the "Slices" field to
a value greater than one. The Image>Stacks submenu contains commands for
common stack operations.

Selections

Selections are user defined areas or lines within an image. Only one selection
can be active at a time. Area selections are created using the rectangular,
elliptical, polygonal and freehand selection tools. Area selections can be
measured (Analyze>Measure), filtered, filled (Edit>Fill) or drawn (Edit>Draw).
Line selections are created using the straight, segmented and freehand line
selection tools. Use Edit>Draw to draw the line in the current color. The length of
line selections can be measured using Analyze>Measure.

Selections can be moved by clicking and dragging. The status bar displays the
coordinates of the upper left corner of the selection (or the bounding rectangle for
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non-rectangular selections) as it is being moved. Notice that the cursor changes
to an arrow when it is within the selection. To move the contents of a rectangular
selection, rather than the selection itself, Edit>Copy (c), Edit>Paste (v), and then
click within the selection and drag. Use the arrow keys to nudge selections one
pixel at a time in any direction.

Rectangular and elliptical selections can be resized. As the selection is resized,
the width and height are displayed in the status bar. Use the arrow keys with the
alt key down to stretch rectangular or elliptical selections one pixel at a time.

To delete a selection, choose any of the selection tools and click outside the
selection, or use Edit>Selection>Select None (shift-a). Use
Edit>Selection>Restore Selection (shift-e) to restore a selection back after
having deleted it.

A selection can be transferred from one image window to another by activating
the destination window and using Edit>Selection>Restore Selection. Selections
can be saved to disk using File>Save As>Selection and restored using
File>Open. Use the ROI Manager to work with multiple selections.

File Formats
The File>Open command opens TIFF, GIF, JPEG, PNG, DICOM, BMP, PGM and
FITS images. It also opens lookup tables and selections. In addition, the
File>Import submenu provides access to plugins for reading "raw" files, images
in ASCII format, and for loading images over the network using a URL. To import
a raw file, you must know certain information about the layout, including the image
size and the offset to the image data. Files can be saved in TIFF, GIF, JPEG,
PNG, PGM, FITS, tab-delimited text, and raw formats. Add support for additional
formats by downloading or writing plugins. The Bio-Formats plugin from the
University of Wisconsin opens 69 different life sciences image file formats.

Plugins
ImageJ's functionality can be expanded through the use of plugins written in Java.
Plugins can add support for new file formats or they can filter or analyze images.
Plugins located in ImageJ's "plugins" folder are automatically installed in the
Plugins menu or they can be installed in other menus using Plugins/Hot
Keys/Install Plugin. Plugins can be created or modified using Plugins/Edit. More
than 150 example plugins are available for download from the ImageJ website.

Lookup Tables

Grayscale images are displayed using a color lookup table which describes the
color to be used for each of 256 possible displayed pixel values. Select
alternative color palettes from the Image/Lookup Tables submenu. Use
Image/Adjust/Brightness/Contrast to enhance images by dynamically changing
the lookup table mapping and Analyze/Show LUT to display the lookup table of
the active image.

top | home | contents | previous | next
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